
<!DOCTYPE html>
<html lang="en-AU" style="--theme-color: #e72824">
<head>
    <title>CSI: Miami - S10 Ep. 19 - Network Ten</title>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width,initial-scale=1,maximum-scale=1,user-scalable=0"/>
    <meta name="keywords"/>
    
<script>
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- OneTrust CMP -->
<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js"  type="text/javascript" charset="UTF-8" data-domain-script="62537caf-23b2-4fde-9162-4ee4b05ebda7"></script>

<!-- optanon - standardized api for OneTrust -->
<script src="////production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.2.js" type="text/javascript" async></script>

<script type="text/javascript">
    var StatusReadyValidator = function(){};
    StatusReadyValidator.prototype.status = {
        ads: {
            multiRun: false,
            status: {
                cmp: false,
                adhesion: false,
                adManager: false,
            },
            callback: [],
        }
    };
    StatusReadyValidator.prototype.statusRegister = function(cat, sec, bool, multiRun) {
        var category = this.status[cat];
        if (typeof category !== "object") {
            category = this.status[cat] = {
                status: {},
                callback: [],
                multiRun: multiRun,
            };
        }
        category.status[sec] = bool;
    }
    StatusReadyValidator.prototype.statusUpdate = function(cat, sec, bool) {
        var category = this.status[cat];
        if (typeof category === "object" && [true, false].indexOf(category.status[sec]) > -1) {
            category.status[sec] = bool;
            if (this.statusValidate(cat)) {
                this.runCallback(cat);
            }
        }
    };
    StatusReadyValidator.prototype.statusValidate = function(cat) {
        var category = this.status[cat];
        if (typeof category === "object" && typeof category.status === "object") {
            var sections = Object.keys(category.status);
            return sections.map(function(secName) {return category.status[secName]}).filter(function(secValue){return secValue === false}).length === 0;
        } else {
            return false;
        }
    }
    StatusReadyValidator.prototype.registerCallback = function(cat, callback) {
        var category = this.status[cat];
        if (typeof category === "object" && Array.isArray(category.callback)) {
            category.callback.push(callback);
        }
    }
    StatusReadyValidator.prototype.runCallback = function(cat) {
        var category = this.status[cat];
        if (typeof category === "object" && Array.isArray(category.callback)) {
            category.callback.forEach(function(callback){callback();})
            !category.multiRun && category.callback.splice(0);
        }
    }
    window.statusReadyValidator = new StatusReadyValidator();
</script>

<!-- optanon api bootstrap -->
<script type="text/javascript">
    !function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onIframesReady","onFormsReady","onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();

    window.cbsoptanon.config.push({
        enableServices: false,
        setNpaOnConsentChange: true
    });

    window.cbsoptanon.onAdsReady((_cbsoptanon, adOpts) => {
        window.statusReadyValidator.statusUpdate("ads", "cmp", true);
    });

    window.statusReadyValidator.registerCallback("ads", function () {
        googletag.cmd.push(function() {
            googletag.enableServices();
            TenPlay.Page.renderAdSlots();
        });
    })
</script>

    <link rel="icon" href="/images/favicon.png" type="image/x-icon" />
    <script async="" type="text/javascript" src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async="" type="text/javascript" src="//secure-dcr.imrworldwide.com/novms/js/2/ggcmb510.js"></script>
<link rel="stylesheet" charset="UTF-8" href="https://cdnjs.cloudflare.com/ajax/libs/slick-carousel/1.9.0/slick.min.css">
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/slick-carousel/1.9.0/slick-theme.min.css">

    
            <script type="application/ld+json">
            {"@context":"http://schema.org","@graph":[{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://10play.com.au/csi-miami","name":"CSI: Miami"}},{"@type":"ListItem","position":2,"item":{"@id":"https://10play.com.au/csi-miami/episodes","name":"Episodes"}},{"@type":"ListItem","position":3,"item":{"@id":"https://10play.com.au/csi-miami/episodes/season-10","name":"Season 10"}},{"@type":"ListItem","position":4,"item":{"@id":"https://10play.com.au/csi-miami/episodes/season-10/episode-19/tpv220805bhpxc","name":"CSI: Miami - S10 Ep. 19"}}]},{"@type":"VideoObject","name":"CSI: Miami - S10 Ep. 19","description":"When one of the CSI\u0027s biggest enemies is murdered, Horatio must determine which of his team members is a suspect.","keywords":null,"url":"https://10play.com.au/csi-miami/episodes/season-10/episode-19/tpv220805bhpxc","contentUrl":"https://10play.com.au/csi-miami/episodes/season-10/episode-19/tpv220805bhpxc","image":["https://10play.com.au/ip/vs/507/231/CSIM-epi1019-RE.png?image-profile=image_full\u0026io=landscape"],"thumbnailUrl":"https://10play.com.au/ip/vs/507/231/CSIM-epi1019-RE.png?image-profile=image_full\u0026io=landscape","dateCreated":"2022-08-31T22:53:00+00:00","datePublished":"2022-08-31T22:53:00+00:00","dateModified":"2022-08-30T23:15:48+00:00","uploadDate":"2022-08-30T23:15:48+00:00","publisher":{"@type":"Organization","name":"10 play","logo":{"@type":"ImageObject","url":"https://10play.com.au/images/10-icon.png"}},"duration":"PT2502S"}]}
        </script>        

    <script src="https://imasdk.googleapis.com/js/sdkloader/ima3.js?buildId=1663119994" hot-reload></script>

            <!--SearchEngine-->
            <meta name="image" content="https://10play.com.au/ip/vs/507/231/CSIM-epi1019-RE.png?image-profile=image_full&amp;io=landscape"/>
        <!--Google-->
            <meta itemprop="name" content="CSI: Miami - S10 Ep. 19"/>
            <meta itemprop="image" content="https://10play.com.au/ip/vs/507/231/CSIM-epi1019-RE.png?image-profile=image_full&amp;io=landscape"/>
        <!--Facebook-->
            <meta name="og:title" content="CSI: Miami - S10 Ep. 19"/>
            <meta name="og:url" content="https://10play.com.au/csi-miami/episodes/season-10/episode-19/tpv220805bhpxc"/>
            <meta name="og:description" content="When one of the CSI&#x27;s biggest enemies is murdered, Horatio must determine which of his team members is a suspect."/>
            <meta name="og:image" content="https://10play.com.au/ip/vs/507/231/CSIM-epi1019-RE.png?image-profile=image_full&amp;io=landscape"/>
            <meta name="og:site_name" content="10 play"/>
            <meta name="og:locale" content="en_GB"/>
            <meta name="fb:app_id" content="182472175873300"/>
            <meta name="og:type" content="article"/>
        <!--Twitter-->
            <meta name="twitter:card" content="summary_large_image"/>
            <meta name="twitter:title" content="CSI: Miami - S10 Ep. 19"/>
            <meta name="twitter:image:src" content="https://10play.com.au/ip/vs/507/231/CSIM-epi1019-RE.png?image-profile=image_full&amp;io=landscape"/>
            <meta name="twitter:site" content="@tenplay"/>
            <meta name="twitter:description" content="When one of the CSI&#x27;s biggest enemies is murdered, Horatio must determine which of his team members is a suspect."/>
            <meta name="twitter:creator" content="tenplay"/>

    <link rel="stylesheet" href="/css/main.css?buildId=1663119994" />
    <link rel="canonical" href="https://10play.com.au/csi-miami/episodes/season-10/episode-19/tpv220805bhpxc"/>

    <meta name="description" content="When one of the CSI&#x27;s biggest enemies is murdered, Horatio must determine which of his team members is a suspect." />
    <script>var apiUrl = "https://10play.com.au";</script>
    <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>
    <script async src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;version=v2.5"></script>
    <script async="" defer="" src="//platform.instagram.com/en_US/embeds.js"></script>
    
        <!-- Start of Tealium utag.sync.js script ---><script src="//tags.tiqcdn.com/utag/10/10playsite/prod/utag.sync.js"></script><!-- End of Tealium utag.sync.js script --->
        <script>
            var TealiumData = {"siteDomain":"https://10play.com.au","siteName":"10 play","pageContentName":"CSI: Miami - S10 Ep. 19","siteSubSection1":"csi-miami","siteSubSection2":"episodes","siteSubSection3":"season-10","siteSubSection4":"episode-19","siteSubSection5":"tpv220805bhpxc","showKey":null,"showName":"CSI: Miami","showNameTargeting":"csi_miami","showProgramClassification":"M","showGenre":["Crime","Drama"],"showGenreSecondary":["Procedural"],"showGenres":["drama","crime","procedural"],"showChannel":"bold","siteSection":"Shows","showContentCategory":"Episodes","showContentId":null,"tealium_event":"show_episode_view","pageContentId":"tpv220805bhpxc","videoContentCategories":["episodes"],"showContentVideoType":"Full Episode","showContentFormatType":"Long Form","showContentSeason":"Season 10","showContentName":"CSI: Miami - S10 Ep. 19","contentPublishDate":"2022-08-31T22:53:00+00:00","pageContentPublishDate":"2022-08-31T22:53:00+00:00","pageContentType":"Video","showContentVideoPlatform":"brightcove","showContentVideoId":"9000000000051271"};
        </script>

    <script type="text/javascript" src="/static/ads.js"></script>
    <script type="text/javascript" src="/js/GlobalHeader.compiled.js?buildId=1663119994" hot-reload></script>
    <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://sordidsmile.com/v2vczMK-kM10lt0PB5ZUFZAANp3I1eHk3TZ8Yzqp5_sbUWJoZS8Q1qHSNromY_--K_A",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){function t(){(t.q=t.q||[]).push(arguments)}t.v=1,o.admiral=o.admiral||t})(window);!(function(o,t,n,c){function e(n){(function(){try{return(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]>0}catch(o){}return!1})()&&(n=o[t].pubads())&&n.setTargeting("admiral-engaged","true")}(c=o[t]=o[t]||{}).cmd=c.cmd||[],typeof c.pubads===n?e():typeof c.cmd.unshift===n?c.cmd.unshift(e):c.cmd.push(e)})(window,"googletag","function");</script>
</head>
<body class="showpage" style="--theme-color: #e72824">

        <script type="text/javascript">(function(a,b,c,d){a='//tags.tiqcdn.com/utag/10/10playsite/prod/utag.js';b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);})();</script>


    
        
<div id="nav"><header class="global-header  global-header--show-page  global-header--fixed"><div class="container d-flex"><h1 class="global-header__logo"><a href="/" class="global-header__logo-link" aria-label="Return to homepage"><div class="logo"></div></a></h1><button role="button" aria-label="Mobile Menu Button" class="menu__hamburger"></button><div class="global-header__primary"><ul class="global-header__navigation" role="navigation" aria-label="Main Navigation"><li><a class="hide-desktop" href="/shows">Shows</a><button class="megamenu__toggle hide-tablet">Shows <span class="icon-angle-down"></span></button><div class="megamenu "><ul class="megamenu__quicklinks"><li><a href="/news">10 News First</a></li><li><a href="/sport">10 Sport</a></li><li><a href="/10-play-trending">10 Trending</a></li></ul><div class="megamenu__menus"><div class="close-container"><button class="close-x close-x--light"></button></div><div class="container"><div class="row"><div class="megamenu__menu--white megamenu__menu--bordered col-sm-12 col-md-5" data-tp="MjQ2OTMx"><div class="megamenu__menu"><h3 class="megamenu__heading--text">Catch Up On...</h3><ul><li><a href="/the-amazing-race-australia" class="megamenu__shows" style="background-image:url(https://10play.com.au/ip/s3/2022/07/18/696063e6b9c3f2e34acf25e1c4784eff-1164871.jpg?image-profile=image_small&amp;io=landscape)">The Amazing Race Australia<small>The Amazing Race Australia</small><span class="megamenu__shows-category"></span></a></li><li><a href="/brain-eisteddfod" class="megamenu__shows" style="background-image:url(https://10play.com.au/ip/s3/2022/06/29/3a3e7ee4060d67f97f007dd04fdd15b4-1160454.jpg?image-profile=image_small&amp;io=landscape)">Shaun Micallef’s Brain Eisteddfod<small>Shaun Micallef’s Brain Eisteddfod</small><span class="megamenu__shows-category"></span></a></li><li><a href="/survivor-south-africa" class="megamenu__shows" style="background-image:url(https://10play.com.au/ip/s3/2022/06/20/9e8553f8b8eb9f2aea93df2bfb59e0c9-1157561.jpg?image-profile=image_small&amp;io=landscape)">Survivor South Africa<small>Survivor South Africa</small><span class="megamenu__shows-category"></span></a></li></ul></div></div><div class="megamenu__menu--grey col-sm-12 col-md-7"><div class="row"><div class="megamenu__menu col-sm-6" data-tp="MjQ2OTMz"><h3 class="megamenu__heading--text">Featured TV Shows</h3><ul><li><a href="/the-amazing-race-australia">The Amazing Race Australia</a></li><li><a href="/hunted">Hunted</a></li><li><a href="/the-real-love-boat">The Real Love Boat</a></li><li><a href="/brain-eisteddfod">Shaun Micallef’s Brain Eisteddfod</a></li><li><a href="/gogglebox">Gogglebox</a></li><li><a href="/the-masked-singer">The Masked Singer Australia</a></li><li><a href="/survivor-south-africa">Survivor South Africa</a></li><li><a href="/masterchef">MasterChef</a></li><li><a href="/the-cheap-seats">The Cheap Seats</a></li><li><a href="/ultimate-classroom">Ultimate Classroom</a></li></ul></div><div class="megamenu__menu col-sm-6"><h3 class="megamenu__heading--text">Shows By Genre</h3><ul><li><a href="/shows/adventure">Adventure</a></li><li><a href="/shows/comedy">Comedy</a></li><li><a href="/shows/crime">Crime</a></li><li><a href="/shows/documentary">Documentary</a></li><li><a href="/shows/drama">Drama</a></li><li><a href="/shows/kids">Kids</a></li><li><a href="/shows/lifestyle">Lifestyle</a></li><li><a href="/shows/light-entertainment">Light Entertainment</a></li><li><a href="/shows/movie">Movies</a></li><li><a href="/shows/news">News</a></li><li><a href="/shows/reality">Reality</a></li><li><a href="/shows/sport">Sport</a></li><li><a href="/shows/thriller">Thriller</a></li><li><a href="/shows" class="megamenu__more" style="color:#1882f8">View All Shows<i class="icon-arrow-right"></i></a></li></ul></div></div></div></div></div></div><div class="megamenu__search"><div class="search-form"><form action="/search?field"><input type="text" value="" placeholder="Search for shows, people, recipes" class="search-form__input"/><button class="search-form__button" aria-label="Search" type="submit"><i class="search-form__icon icon-search"></i></button></form></div></div><div class="megamenu__backdrop"></div></div></li><li><a href="/live">Live TV</a></li><li><a href="/tv-guide">TV Guide</a></li><li><button class="megamenu__toggle undefined">News &amp; Sport <span class="icon-angle-down"></span></button><div class="megamenu "><ul class="megamenu__quicklinks"><li><a href="/news">10 News First</a></li><li><a href="/sport">10 Sport</a></li><li><a href="/10-play-trending">10 Trending</a></li></ul><div class="megamenu__menus"><div class="close-container"><button class="close-x close-x--light"></button></div><div class="container"><div class="row"><div class="megamenu__menu--white megamenu__menu--bordered col-sm-12 col-md-5"><div class="row"><div class="megamenu__menu col-sm-6"><h3 class="megamenu__heading--image"><img src="/images/10-news-first.png" alt="10 News First"/></h3><ul><li><a href="/news/national">National</a></li><li><a href="/news/sydney">Sydney</a></li><li><a href="/theproject">The Project</a></li><li><a href="/studio-10">Studio 10</a></li><li><a href="/news" class="megamenu__more" style="color:#1882f8">View All News<i class="icon-arrow-right"></i></a></li></ul></div><div class="megamenu__menu col-sm-6"><h3 class="megamenu__heading--image"><img src="/images/10-sport.png" alt="10 Sport"/></h3><ul><li><a href="/football">Football</a></li><li><a href="/bellator">Bellator</a></li><li><a href="/australia-cup">Australia Cup</a></li><li><a href="/wow-women-of-wrestling">WOW - Women Of Wrestling</a></li><li><a href="/a-league">A-League</a></li><li><a href="/socceroos">Socceroos</a></li><li><a href="/formula-1">Formula 1</a></li><li><a href="/sport" class="megamenu__more" style="color:#1882f8">View All Sports<i class="icon-arrow-right"></i></a></li></ul></div></div></div><div class="megamenu__menu--grey col-sm-12 col-md-7"><section class="megamenu__menu col-sm-12"><h3 class="megamenu__heading--image"><a href="/10-play-trending" aria-label="Link to trending page"><img src="/images/10-play-trending.png" alt="10 Play Trending"/></a></h3><ul class="trending-list"><li><a href="/who-the-bleep-did-i-marry/articles/who-the-bleep-did-i-marry-is-10-plays-latest-true-crime-documentary-show-that-will-leave-you-shocked/tpa220915znufe" style="background-image:url(&quot;https://10play.com.au/ip/s3/2022/09/15/61ca1adf42c1b6d96b069f2c1b5b60cf-1179872.jpg?image-profile=image_small&amp;io=landscape&quot;)">Who The (Bleep) Did I Marry? Is 10 play’s Latest True Crime Documentary Show That Will Leave You Shocked</a></li><li><a href="/the-amazing-race-australia/web-extras/season-3/the-amazing-race-australia-are-off-to-colombia/tpv220914klguv" style="background-image:url(&quot;https://10play.com.au/ip/vs/101/987/tpncp-TARA31809SU40-750000_1280x720_2072432195669.jpg?image-profile=image_small&amp;io=landscape&quot;)">The Amazing Race Australia Are Off To Colombia<br/><span>It&#x27;s chaos in Colombia! Will this be the last episode for favourites Heath and Toni? The Amazing Race Australia continues 7.30 Sunday on 10 an 10 play.</span></a></li><li><a href="/the-real-love-boat/web-extras/season-1/meet-jay-sally/tpv220912axqso" style="background-image:url(&quot;https://10play.com.au/ip/vs/384/771/nbncp-1-TRLB122CS40C-750000_1280x720_2071649347560.jpg?image-profile=image_small&amp;io=landscape&quot;)">Meet Jay &amp; Sally<br/><span>Meet single parents, Sally and Jay. The Real Love Boat sets sail on Wednesday, October 5 on 10 and 10 play on demand.</span></a></li><li><a href="/the-traitors/web-extras/season-1/the-traitors-is-coming-soon-to-10-and-10-play/tpv220912rfake" style="background-image:url(&quot;https://10play.com.au/ip/vs/376/962/2172209130664867607.jpg?image-profile=image_small&amp;io=landscape&quot;)">The Traitors Is Coming Soon To 10 and 10 play<br/><span>Welcome to a new kind of game. Rodger Corser hosts the new nail-biting psychological adventure series, coming soon to 10 and 10 play on demand.</span></a></li></ul><a class="megamenu_more trending" href="/10-play-trending">View All Trending<i class="icon-arrow-right"></i></a></section></div></div></div></div><div class="megamenu__search"><div class="search-form"><form action="/search?field"><input type="text" value="" placeholder="Search for shows, people, recipes" class="search-form__input"/><button class="search-form__button" aria-label="Search" type="submit"><i class="search-form__icon icon-search"></i></button></form></div></div><div class="megamenu__backdrop"></div></div></li><li><a href="/kids-hub">Kids</a></li><li><a href="/win">Win</a></li><li class="global-header__search"><button role="button" aria-label="Expand search area"><span class="icon-search"></span></button></li><div></div></ul></div><div class="global-header__search"><button role="button" aria-label="Expand search overlay"><span class="icon-search"></span></button></div></div></header></div>

<script>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</script>

    

<main>
    <div class="content__wrapper">
        <div class="content__wrapper--inner">
            


<div id="showPage"><section role="main" class="main__section"><div class="page-title-bar "><div class="container"><div class="d-flex justify-between flex-no-wrap align-center"><a href="/csi-miami"><h1 data-tp="MjU4NjEz">CSI: Miami</h1></a></div></div></div><div class="show-video"><div class="container"><div class="row mini-gutters"><div class="col-12 col-marquee-main show-video__player"><div class="main break-mobile-padding"><div class="videoContainer"><div id="avia_player"></div><div class="videoContainer--memberGated" style="--background-image-url:url(https://10play.com.au/ip/vs/507/231/CSIM-epi1019-RE.png?image-profile=image_large&amp;io=landscape)"><div class="videoContainer--memberGated-container"><div class="videoContainer--memberGated-box"><h4>Sign in to watch this video</h4><p>Not a member? Create your free account now</p><button class="btn"><span class="icon-user-circle"></span>Stream Free</button></div></div></div></div></div></div><div class="col-12 col-marquee-side show-video__info"><div class="side"><div class="show-video__sponsor"></div><h3>CSI: Miami - S10 Ep. 19<br/><small><span class="show-rating">M</span><span class="show-rating-spacer"> | </span><span class="show-genre">Drama</span></small></h3><input type="checkbox" class="show-video__details-toggle" id="show-video__details"/><label class="show-video__details-show" for="show-video__details">Details <span class="icon-angle-down"></span></label><div class="show-video__details"><span><strong>Air Date:</strong> <!-- -->Thu 1 Sep 2022</span><span><strong>Expires:</strong> <!-- -->in 12 months</span><p>When one of the CSI&#x27;s biggest enemies is murdered, Horatio must determine which of his team members is a suspect.</p><ul class="show-video__actions"><li><button href="#" class="favourite-content btn btn--rounded"><form><input type="checkbox" id="trackContent" class="favourite-content__heart"/><label for="trackContent" class="favourite-content__heart">Add to my Shows</label></form></button></li></ul> <div class="content-outer content-outer--dark content-outer--origin-bottom-left"><button class="btn btn--rounded btn--social-share"><span class="btn__icon icon-share"></span>Share</button><div class="content-inner"><div class="share share__video"><div class="share__date"></div><div class="share__social"><div class="social__links social__links--horizontal"><a target="_blank" class="icon-facebook" href="#"></a><a target="_blank" class="icon-twitter" href="#"></a><a target="_blank" class="icon-pinterest-p" href="#"></a><a target="_blank" class="icon-envelope" href="#"></a></div></div></div></div></div></div></div></div></div></div></div><div class="tab__list"><div class="container d-flex"><div class="tab__list-item tab__list--active">Episodes</div><a href="/csi-miami/about" class="tab__list-item tab__link">Home</a></div></div><div class="tab__content"><div class="content"><div class="container relative"><div class="content__header" data-tp="MjgxMzMz"><h3>Episodes<!-- --> </h3></div><div class="undefined content__grid row"><div class="content__tiles-tile mrec-container"><div class="mrec"><span>Advertisement</span></div></div><div style="order:0" class="content__grid-tile undefined"><a href="/csi-miami/episodes/season-10/episode-1/tpv220805ydkpi" data-tp="MTYwMDcxMg=="><div class="row no-gutters"><div class="imageContainer col-6 col-md-12"><img src="/images/index_thumb.png" alt="image-placeholder"/><span class="card__meta duration">42 mins</span></div><div class="textContainer col-6 col-md-12"><h3>S10 Ep. 1 - Countermeasures</h3><p>Horatio saves Natalia and sets out to track down Randy North before serial killer Jack Toller strikes again. However, a seriously-wounded Horatio begins having visions of his dead wife Marisol.</p></div></div></a></div><div style="order:10" class="content__grid-tile undefined"><a href="/csi-miami/episodes/season-10/episode-2/tpv220805twbup" data-tp="MTYwMDcxMw=="><div class="row no-gutters"><div class="imageContainer col-6 col-md-12"><img src="/images/index_thumb.png" alt="image-placeholder"/><span class="card__meta duration">42 mins</span></div><div class="textContainer col-6 col-md-12"><h3>S10 Ep. 2 - Stiff</h3><p>The team tries to figure out who killed a male escort who was found in a hotel cabana.</p></div></div></a></div><div style="order:20" class="content__grid-tile undefined"><a href="/csi-miami/episodes/season-10/episode-3/tpv220805yjtdb" data-tp="MTYwMDcxNA=="><div class="row no-gutters"><div class="imageContainer col-6 col-md-12"><img src="/images/index_thumb.png" alt="image-placeholder"/><span class="card__meta duration">41 mins</span></div><div class="textContainer col-6 col-md-12"><h3>S10 Ep. 3 - Blown Away</h3><p>Solving the death of a Dade University co-ed becomes complicated when the crime scene is destroyed by a tornado, but the investigation soon focuses on a team of storm chasers.</p></div></div></a></div><div style="order:30" class="content__grid-tile undefined"><a href="/csi-miami/episodes/season-10/episode-4/tpv220805dfmhi" data-tp="MTYwMDcxOA=="><div class="row no-gutters"><div class="imageContainer col-6 col-md-12"><img src="/images/index_thumb.png" alt="image-placeholder"/><span class="card__meta duration">41 mins</span></div><div class="textContainer col-6 col-md-12"><h3>S10 Ep. 4 - Look Who&#x27;s Taunting</h3><p>The team races against time to catch a sadistic man who is torturing and killing prostitutes before he kills his latest victim.</p></div></div></a></div><div style="order:40" class="content__grid-tile undefined"><a href="/csi-miami/episodes/season-10/episode-5/tpv220805dqsjp" data-tp="MTYwMDcxOQ=="><div class="row no-gutters"><div class="imageContainer col-6 col-md-12"><img src="/images/index_thumb.png" alt="image-placeholder"/><span class="card__meta duration">41 mins</span></div><div class="textContainer col-6 col-md-12"><h3>S10 Ep. 5 - Killer Regrets</h3><p>Horatio turns to prisoner Memmo Fiero for help as he tries to find a notorious Mala Noche assassin who has targeted a Mexican sheriff and her family.</p></div></div></a></div><div style="order:50" class="content__grid-tile undefined"><a href="/csi-miami/episodes/season-10/episode-6/tpv220805mzxln" data-tp="MTcwMDcxMA=="><div class="row no-gutters"><div class="imageContainer col-6 col-md-12"><img src="/images/index_thumb.png" alt="image-placeholder"/><span class="card__meta duration">40 mins</span></div><div class="textContainer col-6 col-md-12"><h3>S10 Ep. 6 - By The Book</h3><p>The team investigates the bizarre death of a housekeeper in the island mansion that belongs to a famed vampire novelist.</p></div></div></a></div><div style="order:60" class="content__grid-tile undefined"><a href="/csi-miami/episodes/season-10/episode-7/tpv220805qlkzh" data-tp="MTcwMDcxNw=="><div class="row no-gutters"><div class="imageContainer col-6 col-md-12"><img src="/images/index_thumb.png" alt="image-placeholder"/><span class="card__meta duration">42 mins</span></div><div class="textContainer col-6 col-md-12"><h3>S10 Ep. 7 - Sinner Takes All</h3><p>A masked robber crashes into an illegal high-stakes poker game, leaving a Hollywood producer dead. But the evidence suggests that he was killed by a hidden second accomplice.</p></div></div></a></div><div style="order:70" class="content__grid-tile undefined"><a href="/csi-miami/episodes/season-10/episode-8/tpv220805ifdkn" data-tp="MTkwMDcxMQ=="><div class="row no-gutters"><div class="imageContainer col-6 col-md-12"><img src="/images/index_thumb.png" alt="image-placeholder"/><span class="card__meta duration">41 mins</span></div><div class="textContainer col-6 col-md-12"><h3>S10 Ep. 8 - Dead Ringer</h3><p>When another body of a dead woman is found on the beach, Horatio thinks that Esteban Navarro, the &quot;Miami Taunter,&quot; has struck again.</p></div></div></a></div></div><p class="load-more"><button>Load More</button></p></div></div><div class="dropdown__float--right show-dropdown"><div class="container"><header class="content__header"><div class="dropdown "><div class="dropdown__title  dropdown__filled"><span class="label">Season 10</span><span class="dropdown__icon icon-angle-down "></span></div></div></header></div></div></div></section></div>
<script>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</script>

<div id="quick-links"><div class="content quicklinks"><div class="container"><div class="row no-gutters"><header class="content__header"><h3>More from 10</h3></header><div class="content__wrapper"><div class="row"><div class="col-12 col-md-6 col-lg-3"><div class="ql ql-1"></div></div><div class="col-12 col-md-6 col-lg-3"><div class="ql ql-2"></div></div><div class="col-12 col-md-6 col-lg-3"><div class="ql ql-3"></div></div><div class="col-12 col-md-6 col-lg-3"><div class="ql ql-4"></div></div></div></div></div></div></div></div>
        </div>
    </div>
</main>

    
        
<div id="footer"><footer class="global-footer"><div class="global-footer__navigation"><div class="container"><div class="row no-gutters"><div class="col-md-6"><div class="global-footer__links-container"><h4 class="global-footer__headline">Featured TV Shows</h4><input type="checkbox" class="global-footer__accordion-input" id="global-footer__accordionOne"/><label class="global-footer__accordion-label" for="global-footer__accordionOne"><span class="global-footer__accordion-icon"></span></label><ul class="global-footer__links global-footer__links--columns"><li><a href="/the-amazing-race-australia" class="global-footer__link">The Amazing Race Australia</a></li><li><a href="/australian-survivor" class="global-footer__link">Australian Survivor</a></li><li><a href="/the-bachelor" class="global-footer__link">The Bachelor</a></li><li><a href="/the-bachelorette" class="global-footer__link">The Bachelorette</a></li><li><a href="/bachelor-in-paradise-us" class="global-footer__link">Bachelor In Paradise US</a></li><li><a href="/the-big-bang-theory" class="global-footer__link">The Big Bang Theory</a></li><li><a href="/the-cheap-seats" class="global-footer__link">The Cheap Seats</a></li><li><a href="/the-dog-house" class="global-footer__link">The Dog House</a></li><li><a href="/the-dog-house-australia" class="global-footer__link">The Dog House Australia</a></li><li><a href="/first-dates-australia" class="global-footer__link">First Dates Australia</a></li><li><a href="/friends" class="global-footer__link">Friends</a></li><li><a href="/hunted" class="global-footer__link">Hunted</a></li><li><a href="/im-a-celebrity-get-me-out-of-here" class="global-footer__link">I&#x27;m A Celebrity...Get Me Out Of Here!</a></li><li><a href="/the-living-room" class="global-footer__link">The Living Room</a></li><li><a href="/the-masked-singer" class="global-footer__link">The Masked Singer Australia</a></li><li><a href="/masterchef" class="global-footer__link">MasterChef</a></li><li><a href="/neighbours" class="global-footer__link">Neighbours</a></li><li><a href="/ncis" class="global-footer__link">NCIS</a></li><li><a href="/the-office" class="global-footer__link">The Office</a></li><li><a href="/paw-patrol" class="global-footer__link">Paw Patrol</a></li><li><a href="/prisoner" class="global-footer__link">Prisoner</a></li><li><a href="/theproject" class="global-footer__link">The Project</a></li><li><a href="/seinfeld" class="global-footer__link">Seinfeld</a></li><li><a href="/stuff-everyone-should-know-about-australia" class="global-footer__link">Stuff Everyone Should Know About Australia</a></li><li><a href="/survivor-south-africa" class="global-footer__link">Survivor South Africa</a></li><li><a href="/survivor-us" class="global-footer__link">Survivor US</a></li><li><a href="/would-i-lie-to-you" class="global-footer__link">Would I Lie To You?</a></li></ul></div></div><div class="col-md-3 col-middle"><div class="global-footer__links-container"><h4 class="global-footer__headline">Sport</h4><input type="checkbox" class="global-footer__accordion-input" id="global-footer__accordion_mid_index0"/><label class="global-footer__accordion-label" for="global-footer__accordion_mid_index0"><span class="global-footer__accordion-icon"></span></label><ul class="global-footer__links"><li><a href="/football" class="global-footer__link">Football</a></li><li><a href="/bellator" class="global-footer__link">Bellator</a></li><li><a href="/melbourne-cup-carnival" class="global-footer__link">Melbourne Cup Carnival</a></li><li><a href="/motorsport" class="global-footer__link">Motorsport</a></li><li><a href="/rpm" class="global-footer__link">RPM</a></li><li><a href="/formula-1" class="global-footer__link">Formula 1</a></li></ul></div><div class="global-footer__links-container"><h4 class="global-footer__headline">Apps</h4><input type="checkbox" class="global-footer__accordion-input" id="global-footer__accordion_mid_index1"/><label class="global-footer__accordion-label" for="global-footer__accordion_mid_index1"><span class="global-footer__accordion-icon"></span></label><ul class="global-footer__links"><li><a href="https://itunes.apple.com/au/app/10-play/id409289742?mt=8" class="global-footer__link" target="_blank" rel="noopener noreferrer">iOS</a></li><li><a href="https://www.telstra.com.au/tv-movies-music/telstra-tv?tc=G|SEM|TelstraTV|Competitors" class="global-footer__link" target="_blank" rel="noopener noreferrer">Telstra TV</a></li><li><a href="https://play.google.com/store/apps/details?id=au.com.tenplay" class="global-footer__link" target="_blank" rel="noopener noreferrer">Android</a></li><li><a href="https://10play.com.au/apps" class="global-footer__link">Apple TV</a></li><li><a href="https://10play.com.au/apps" class="global-footer__link">FreeviewPlus</a></li><li><a href="https://10play.com.au/apps" class="global-footer__link">Samsung TV</a></li><li><a href="https://10play.com.au/apps" class="global-footer__link">Android TV</a></li><li><a href="https://10play.com.au/apps" class="global-footer__link">Fetch TV</a></li><li><a href="https://10play.com.au/apps" class="global-footer__link">Foxtel iQ</a></li><li><a href="https://10play.com.au/apps" class="global-footer__link">LG TV</a></li></ul></div><div class="global-footer__links-container"><h4 class="global-footer__headline">News</h4><input type="checkbox" class="global-footer__accordion-input" id="global-footer__accordion_mid_index2"/><label class="global-footer__accordion-label" for="global-footer__accordion_mid_index2"><span class="global-footer__accordion-icon"></span></label><ul class="global-footer__links"><li><a href="/news/national" class="global-footer__link">10 News First</a></li></ul></div><div class="global-footer__links-container"><h4 class="global-footer__headline">Podcasts</h4><input type="checkbox" class="global-footer__accordion-input" id="global-footer__accordion_mid_index3"/><label class="global-footer__accordion-label" for="global-footer__accordion_mid_index3"><span class="global-footer__accordion-icon"></span></label><ul class="global-footer__links"><li><a href="https://10play.com.au/the-reality-bite-cocktails-and-roses" class="global-footer__link">The Reality Bite: Cocktails and Roses</a></li><li><a href="https://10play.com.au/shockwaves-the-bali-bombings" class="global-footer__link">Shockwaves: The Bali Bombings</a></li><li><a href="https://10play.com.au/the-professor-and-the-hack" class="global-footer__link">The Professor and The Hack</a></li><li><a href="https://10play.com.au/short-black-with-sandra-sully" class="global-footer__link">Short Black With Sandra Sully</a></li><li><a href="https://10play.com.au/australian-survivor-talking-tribal-podcast" class="global-footer__link">Australian Survivor Talking Tribal</a></li><li><a href="https://10play.com.au/wheres-william-tyrrell" class="global-footer__link">Where&#x27;s William Tyrell?</a></li></ul></div></div><div class="col-md-3"><div class="global-footer__links-container"><h4 class="global-footer__headline">About Network 10</h4><input type="checkbox" class="global-footer__accordion-input" id="global-footer__accordionFive"/><label class="global-footer__accordion-label" for="global-footer__accordionFive"><span class="global-footer__accordion-icon"></span></label><ul class="global-footer__links"><li><a href="https://careers.viacomcbs.com/" class="global-footer__link" target="_blank" rel="noopener noreferrer">Careers</a></li><li><a href="https://www.10viacomcbs.com.au/" class="global-footer__link" target="_blank" rel="noopener noreferrer">Corporate</a></li><li><a href="https://www.paramountplus.com/?ftag=IPP-06-10aag2h" class="global-footer__link" target="_blank" rel="noopener noreferrer">Paramount Plus</a></li><li><a target="_self" rel="noopener noreferrer" href="https://10play.com.au/podcasts" class="global-footer__link">Podcasts</a></li></ul></div><div class="global-footer__links-container"><h4 class="global-footer__headline">Help</h4><input type="checkbox" class="global-footer__accordion-input" id="global-footer__accordionSix"/><label class="global-footer__accordion-label" for="global-footer__accordionSix"><span class="global-footer__accordion-icon"></span></label><ul class="global-footer__links"><li><a href="https://helpdesk.tenplay.com.au/support/home" class="global-footer__link" target="_blank" rel="noopener noreferrer">10 play Support</a></li></ul></div><div class="global-footer__links-container"><h4 class="global-footer__headline">Our Partners</h4><input type="checkbox" class="global-footer__accordion-input" id="global-footer__accordionSeven"/><label class="global-footer__accordion-label" for="global-footer__accordionSeven"><span class="global-footer__accordion-icon"></span></label><ul class="global-footer__links"><li><a href="https://www.itvsn.com.au/" class="global-footer__link" target="_blank" rel="noopener noreferrer">TVSN</a></li><li><a href="https://www.10travlr.com.au/" class="global-footer__link" target="_blank" rel="noopener noreferrer">10 Travlr</a></li></ul></div><div class="global-footer__links-container"><h4 class="global-footer__headline">On Network 10</h4><input type="checkbox" class="global-footer__accordion-input" id="global-footer__accordionEight"/><label class="global-footer__accordion-label" for="global-footer__accordionEight"><span class="global-footer__accordion-icon"></span></label><ul class="global-footer__links"><li><a href="/shows" class="global-footer__link">10, 10 Peach, 10 Shake &amp; 10 Bold TV Shows</a></li><li><a href="/tv-guide" class="global-footer__link">Check TV Guide</a></li><li><a href="/live" class="global-footer__link">Watch LIVE</a></li><li><a href="/10-play-trending/articles" class="global-footer__link">10 play Trending</a></li></ul></div><div class="global-footer__links-container"><h4 class="global-footer__headline">Social</h4><input type="checkbox" class="global-footer__accordion-input" id="global-footer__accordionNine"/><label class="global-footer__accordion-label" for="global-footer__accordionNine"><span class="global-footer__accordion-icon"></span></label><ul class="global-footer__links"><li><a href="/social-community-guidelines" class="global-footer__link">Social Community Guidelines</a></li><li class="social__links social__links--horizontal"><a class="icon-facebook" href="https://www.facebook.com/Channel10" rel="noopener noreferrer" target="_blank" aria-label="Visit us on Facebook"></a><a class="icon-twitter" href="https://twitter.com/channel10au" rel="noopener noreferrer" target="_blank" aria-label="Visit us on Twitter"></a><a class="icon-instagram" href="https://www.instagram.com/channel10au/" rel="noopener noreferrer" target="_blank" aria-label="Visit us on Instagram"></a></li></ul></div></div></div></div></div><div class="global-footer__logos-container"><ul class=" global-footer__logos"><li><a class="global-footer__logos-link" href="https://10play.com.au/"><img src="/images/10-play-Logo.png" alt="10 Play" class="global-footer__logo"/></a></li><li><a class="global-footer__logos-link" href="https://10play.com.au/live/bold"><img src="/images/10-Bold-Logo.png" alt="10 Bold" class="global-footer__logo"/></a></li><li><a class="global-footer__logos-link" href="https://10play.com.au/live/peach"><img src="/images/10-Peach-Logo.png" alt="10 Peach" class="global-footer__logo"/></a></li><li><a class="global-footer__logos-link" href="https://10play.com.au/live/shake"><img src="/images/10-Shake-Logo.png" alt="10 Shake" class="global-footer__logo"/></a></li><li><a class="global-footer__logos-link" href="https://www.paramountplus.com/?ftag=IPP-06-10aag2h" target="_blank" rel="noopener noreferrer"><img src="/images/PPlus-Logo.png" alt="Paramount Plus" class="global-footer__logo"/></a></li></ul></div><div class="global-footer__boilerplate"><ul class="global-footer__boilerplate-links"><li><a href="https://www.10viacomcbs.com.au/advertise/why-10/" class="global-footer__boilerplate-link">Advertise with Us</a></li><li><a href="/terms-of-use" class="global-footer__boilerplate-link">Terms of Use</a></li><li><a rel="noopener noreferrer" target="_blank" href="https://www.viacomcbsprivacy.com/en/policy" class="global-footer__boilerplate-link">Privacy Policy</a></li><li><a href="https://helpdesk.tenplay.com.au/support/solutions/folders/16000017381" class="global-footer__boilerplate-link">FAQs</a></li><li><a href="https://careers.viacomcbs.com/" class="global-footer__boilerplate-link">Careers</a></li><li><a href="https://www.10viacomcbs.com.au/" class="global-footer__boilerplate-link">Corporate</a></li><li><a href="/contact-us" class="global-footer__boilerplate-link">Contact Us</a></li></ul><p class="global-footer__boilerplate-text acknowledgement-text">We acknowledge the Aboriginal and Torres Strait Islander peoples as the First Australians and the Traditional Custodians of the lands and waterways on which we live, work and play. We pay our respects to Elders past and present.</p><p class="global-footer__boilerplate-text">© <!-- -->2022<!-- --> Network Ten Pty Limited</p></div></footer></div>

    

<script src="/js/Vendor.compiled.js?buildId=1663119994" hot-reload></script>

    <script src="/js/playerBase.compiled.js?buildId=1663119994" hot-reload></script>
    
<link rel="stylesheet" href="https://secure.widget.cloud.opta.net/v3/css/v3.all.opta-widgets.css">
<script>var opta_settings = { subscription_id: '2a0395844f041be771e68e22942f0cc4', language: 'en_GB', timezone: 'Europe/London' };</script>
<script src="https://secure.widget.cloud.opta.net/v3/v3.opta-widgets.js"></script>


<script src="/js/MyAccountManager.compiled.js?buildId=1663119994" hot-reload></script>
<script src="/js/ShowsIndex.compiled.js?buildId=1663119994" hot-reload></script>
<script type="text/javascript" src="https://z.moatads.com/cbsprebidheader506831276743/moatheader.js"></script>
<script>
    try {
        const indexMod = Object.keys(TenPlay).find(function(prop){return prop.indexOf("ndex") > 0});
        TenPlay.Page = TenPlay[indexMod].Page;
        TenPlay.Page.init();
    } catch (err) {
        console.error("Could not init page", err);
    }
</script>


<script type="text/javascript" src="//secure-au.imrworldwide.com/v60.js"></script>
<script type="text/javascript">
    var pvar = { cid: "network-ten", content: "0", server: "secure-gl" };
    var trac = nol_t(pvar);
    trac.record().post();
</script>
<noscript>
    <div>
    <img src="//secure-au.imrworldwide.com/cgi-bin/m?ci=network-ten&amp;cg=0&amp;cc=1&amp;ts=noscript" width="1" height="1" alt="" />
    </div>
</noscript>

</body>
</html>
